Register    Login    Forum    Search    FAQ

Board index » Hornet 600/599 » Mechanical & Electrical




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: 08 Hornet Running issue
 Post Posted: Wed Sep 13, 2017 7:58 am 
Offline
Hornet Toddler

Joined: Sun Jul 01, 2012 9:09 am
Posts: 46
Hi all,

Right the long story is:

So the bikes high mileage 92k, this is where the first problems start. It Road to work fine, but when I went to go home the bike just sat on the starter and eventually started to tick over (very lumpy) and just kept dying. so got recovered home, found that cylinder 1 wasn't firing, and the compression was down to like 80PSI, needed the bike back on the road so decided I'd buy a new engine.

New Engine - all fitted and plumed in and she ticks over nicely. go to rev it and it bogs and dies, can sometimes build the rev us slowly but still not right, after some checking and some playing with the TPS I gave up and decided to get the bike plugged in for diagnostics and it kept coming back with a TPS error, so I sourced another TPS and the bike is still doing the same.

I'm pretty sure the shop said they checked the wiring so could this be and ECU fault? and if I get a new ECU is this going to affect my HISS system, or can I just plug it in and go?

Thanks in advanced,
G


Top 
 Profile  
 
 Post Posted: Thu Sep 14, 2017 9:48 pm 
Offline
Hornet Warrior
User avatar

Joined: Sun Feb 07, 2010 2:31 am
Posts: 210
Location: tunbridge Wells
check that the airbox inlet needle moves freely that caused me grief

_________________
steve B


Top 
 Profile  
 
Display posts from previous:  Sort by  
 
Post new topic Reply to topic  [ 2 posts ] 

Board index » Hornet 600/599 » Mechanical & Electrical


Who is online

Users browsing this forum: Bing [Bot] and 1 guest

 
 

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to: